Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[ Pihole ][ 4.1.0.0 ]Multi-platform, network-wide ad blocker
#1
[Image: 68747470733a2f2f6173736574732e70692d686f6c652e6e.png]

Module is available for:

x64_OS5/OS7 - last version - 4.1.0.0

Download:
"You have not unlocked the download links. Read here to check how you can unlock them."

Dependencies:

ModBase1 > 1.07.01
FaJoCron > 1.02.01
apache > 2.2.29.2
Perl514 > 1.01.02
GLIBC > 1.00.01

Ethernet interface is configured as default to eth0 in setupVars.conf. If you have link agregation configured, change it to bond0.
password: thecus
After install, login to WebUI and go to Tools>>Update lists and click on Update Lists

!!!Auto update function is not tested, consider that if you activate it!!!

Once installed, configure your router to have DHCP clients use the NAS as their DNS server and then any device that connects to your network will have ads blocked without any further configuration. Alternatively, you can manually set each device to use the NAS as its DNS server.

About

Block ads for all your devices without the need to install client-side software. The Pi-hole blocks ads at the DNS-level, so all your devices are protected.
Web Browsers

Cell Phones

Smart TV's

Internet-connected home automation

Anything that communicates with the Internet

[Image: 68747470733a2f2f6173736574732e70692d686f...642e706e67]

Whitelist and blacklist

Domains can be whitelisted and blacklisted using either the web interface or the command line. See the wiki page for more details

[Image: 68747470733a2f2f6173736574732e70692d686f...6c2e706e67]
------------------------------------------------------------------------
[Image: linkedinbutton.jpg][Image: btn_donate_LG.gif]
Please respect my work and dont share my modules
[-] The following 1 user says Thank You to outkastm for this post:
  • DanGarion
Reply
#2
Hey, thanks for getting this on here. One thing I noticed is that I have to manually start Pi-Hole after my NAS boots up. Even though the app is activated it doesn't seem to be starting DNSmasq and PiHole web on bootup.

Anything I can do to fix that?

I've noticed a couple more things. If I try to make changes in settings they don't take. Also I'm seeing this in the error log.

[Fri Jun 02 14:34:21 2017] [notice] caught SIGTERM, shutting down
[Fri Jun 02 14:34:29 2017] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Fri Jun 02 14:34:29 2017] [warn] RSA server certificate CommonName (CN) `www.thecus.com' does NOT match server name!?
[Fri Jun 02 14:34:29 2017] [notice] Digest: generating secret for digest authentication ...
[Fri Jun 02 14:34:29 2017] [notice] Digest: done
[Fri Jun 02 14:34:29 2017] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Fri Jun 02 14:34:29 2017] [warn] RSA server certificate CommonName (CN) `www.thecus.com' does NOT match server name!?
[Fri Jun 02 14:34:30 2017] [notice] Apache/2.2.29 (Unix) mod_ssl/2.2.29 OpenSSL/1.0.1j DAV/2 PHP/5.6.22 configured -- resuming normal operations
sudo: /raid/data/module/ModBase1/system/etc/sudoers is owned by uid 99, should be 0
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin
sudo: /raid/data/module/ModBase1/system/etc/sudoers is owned by uid 99, should be 0
sudo: no valid sudoers sources found, quitting
Reply
#3
RSA is just a warning, if you want to get rid of it from module WebUi go to configuration files and edit httpd.conf and httpd-ssl.conf
Search for the line starting with ServerName localhost and replace localhost with ww.thecus.com. The self signed certificate is created by default with this domain name

If you want to get a real SSL certifcate for your domain or DDNS you can use the module Letsencrypt

Which setting file you want to edit ?

For the error about su, what is your installed version of  ModBase1 module ?
------------------------------------------------------------------------
[Image: linkedinbutton.jpg][Image: btn_donate_LG.gif]
Please respect my work and dont share my modules
[-] The following 1 user says Thank You to outkastm for this post:
  • DanGarion
Reply
#4
(03-06-2017, 12:17 AM)outkastm Wrote: RSA is just a warning, if you want to get rid of it from module WebUi go to configuration files and edit httpd.conf and httpd-ssl.conf
Search for the line starting with ServerName localhost and replace localhost with ww.thecus.com. The self signed certificate is created by default with this domain name

If you want to get a real SSL certifcate for your domain or DDNS you can use the module Letsencrypt

Which setting file you want to edit ?

For the error about su, what is your installed version of  ModBase1 module ?

Sorry I shouldn't have included the RSA stuff, I'm not worried about SSL and certificates.

When I try to update settings in the "Settings" section they do not take when I hit save. I can however edit the setupvars.conf manually. Although that isn't preferred because I don't know all the setting names to add additional settings that I can't get the GUI to take.

I'm using the most up to date version of ModBase1 

Latest Version
1.07.01
Current Version
1.07.01

Module Size
96MB
Release Date
2017-03-06
Developer
Fajo_OutkastM

Also the 1st item. One thing I noticed is that I have to manually start Pi-Hole after my NAS boots up. Even though the app is activated it doesn't seem to be starting DNSmasq and PiHole web on bootup.

Take your time to answer it's not a big deal. Smile
Reply
#5
Ok...i have to run more tests on OS5. I will also update it to latest version
------------------------------------------------------------------------
[Image: linkedinbutton.jpg][Image: btn_donate_LG.gif]
Please respect my work and dont share my modules
[-] The following 1 user says Thank You to outkastm for this post:
  • DanGarion
Reply
#6
Just an FYI, I think the startup delay is just my impatience. It does eventually start up about 3-5 minutes after the NAS boots.
Reply
#7
Probably this is due to some other modules have to start before this
------------------------------------------------------------------------
[Image: linkedinbutton.jpg][Image: btn_donate_LG.gif]
Please respect my work and dont share my modules
Reply
#8
I suppose you use netdata module. You have to update this one first to 1.6.0.1 as there was a small bug on this one.
Then stop/start pihole and check if you can save setting, and if any more errors about su
------------------------------------------------------------------------
[Image: linkedinbutton.jpg][Image: btn_donate_LG.gif]
Please respect my work and dont share my modules
[-] The following 1 user says Thank You to outkastm for this post:
  • DanGarion
Reply
#9
updated to 3.0.1.0
------------------------------------------------------------------------
[Image: linkedinbutton.jpg][Image: btn_donate_LG.gif]
Please respect my work and dont share my modules
[-] The following 1 user says Thank You to outkastm for this post:
  • DanGarion
Reply
#10
Yes I do.

Thanks! I'll update it and then PiHole!

Work 100% now.
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)