Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[ Nextcloud ][ 15.0.0.0 ] OwnCloud fork
#21
Hi OutkastM

Referring this your previous post here:
https://pirinel.ro/forum/showthread.php?...189#pid189


Sorry for the delay on the follow-up - was doing some serious travelling over the past month.
Item (2) and (3) are fixed - now it is just (1).

1) it works following my guide ?
What guide are you referring to?
Please note that I came from version 10; not sure if this makes a difference.

2) Your data is placed inside the Nextcloud module ? You didn't create a folder for data in /raid/data/nextcloud as example, when you first setup nextcloud ?

Once did exactly that.
Don't know the details but there was a need for switching back to these "factory" defaults.

Should I revert back? If yes, how?


Thanks - Will
Reply
#22
install again the last module version.
go to next cloud admin page and if there is any warning about integrity check, scan again
if you had any app installed inside the nextcloud, restore it from Module WebUI: Application control >> Restor app
Normally is never needed to restore defaults
------------------------------------------------------------------------
[Image: linkedinbutton.jpg][Image: btn_donate_LG.gif]
Please respect my work and dont share my modules
Reply
#23
updated to 12.0.2.0
------------------------------------------------------------------------
[Image: linkedinbutton.jpg][Image: btn_donate_LG.gif]
Please respect my work and dont share my modules
Reply
#24
updated to 12.0.3.0
------------------------------------------------------------------------
[Image: linkedinbutton.jpg][Image: btn_donate_LG.gif]
Please respect my work and dont share my modules
Reply
#25
(02-07-2017, 11:24 PM)outkastm Wrote: On OutkastM Repo module you have to update repository, to add NextCloud 12.0.0.2 in AppCenter
Dependency has changed to apache 2.4.x but the last Nextcloud version in Thecus Repo have dependency set to old apache 2.2

(03-10-2017, 12:28 AM)outkastm Wrote: updated to 12.0.3.0

can i install this on thecus n2350?

//Regards
Reply
#26
(12-10-2017, 03:25 AM)chali Wrote:
(02-07-2017, 11:24 PM)outkastm Wrote: On OutkastM Repo module you have to update repository, to add NextCloud 12.0.0.2 in AppCenter
Dependency has changed to apache 2.4.x but the last Nextcloud version in Thecus Repo have dependency set to old apache 2.2

(03-10-2017, 12:28 AM)outkastm Wrote: updated to 12.0.3.0

can i install this on thecus n2350?

//Regards

Unfortunatelly not (yet). N2350 is base on the new arm architecture, there is no 3rd party module developed (yet) for this platform. To create modules for this platform, for some modules (MySQL as example or Python) require to compile directly on the unit. I'm still waiting to get my hands on one unit so i can start creating modules for it. As explained on this post, the compatible modules will contain ARM_OS7 on their name
https://pirinel.ro/showthread.php?tid=76&pid=106#pid106


Attached Files Thumbnail(s)
   
------------------------------------------------------------------------
[Image: linkedinbutton.jpg][Image: btn_donate_LG.gif]
Please respect my work and dont share my modules
Reply
#27
I can try to create this module for arm, but will be based on apache 2.2 and without MySQL, just with SQLite as a databse backend.
------------------------------------------------------------------------
[Image: linkedinbutton.jpg][Image: btn_donate_LG.gif]
Please respect my work and dont share my modules
Reply
#28
i hope i will get a N4350 in the comming weeks to develop modules for arm platform. Nextcloud will be the first on the list
------------------------------------------------------------------------
[Image: linkedinbutton.jpg][Image: btn_donate_LG.gif]
Please respect my work and dont share my modules
Reply
#29
updated to 12.0.4.0
------------------------------------------------------------------------
[Image: linkedinbutton.jpg][Image: btn_donate_LG.gif]
Please respect my work and dont share my modules
Reply
#30
Hi Outkastm,

First of all, great website! Appreciate your work.

I'm having some issues with NextCloud 12.0.4 unfortunately:

[Tue Jan 30 11:45:52.455834 2018] [php7:error] [pid 28471] [client 192.168.2.237:55290] PHP Fatal error: Uncaught Doctrine\\DBAL\\DBALException: Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [14] unable to open database file in /raiddata/0/module/Nextcloud_okm/bin/nextcloud/lib/private/DB/Connection.php:61\nStack trace:\n#0 /raiddata/0/module/Nextcloud_okm/bin/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(992): OC\\DB\\Connection->connect()\n#1 /raiddata/0/module/Nextcloud_okm/bin/nextcloud/lib/private/DB/Connection.php(213): Doctrine\\DBAL\\Connection->executeUpdate('PRAGMA read_unc...', Array, Array)\n#2 /raiddata/0/module/Nextcloud_okm/bin/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(623): OC\\DB\\Connection->executeUpdate('PRAGMA read_unc...')\n#3 /raiddata/0/module/Nextcloud_okm/bin/nextcloud/lib/private/DB/Connection.php(148): Doctrine\\DBAL\\Connection->setTransactionIsolation(2)\n#4 /raiddata/0/module/Nextcloud_okm/bin/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php(172): OC\\DB\\Connection->__construct(Array, Object(Doctrin in /raiddata/0/module/Nextcloud_okm/bin/nextcloud/lib/private/DB/Connection.php on line 61, referer: https://192.168.2.100:31443

This is what I did:
- Installed Apache 2.4
- Installed NextCloud 12.0.4
- Uninstalled NextCloud because I hadn't changed the data dir
- Re-installed it and added the extra config from the module webpage - error does not seem to be related.

Here's the current config:
<?php
$CONFIG = array (
'instanceid' => 'ocr5zx58pmkq',
'passwordsalt' => '7D9axerhvuqa9ngzhzSDN7IIFTt5WW',
'secret' => 'AsB4icCkgY0jFdI8oIjJ15SEXcRw73B633F0UvzSX7drVyCv',
'trusted_domains' =>
array (
0 => '192.168.2.100',
1 => 'onthewifi.com',
),
'datadirectory' => '/raiddata/0/nextcloud/data',
'overwrite.cli.url' => 'https://192.168.2.100:31443',
'dbtype' => 'sqlite3',
'version' => '12.0.4.3',
'installed' => true,
'updater.secret' => '$2y$10$H9lNa3iXXc4LI4hGcRiIiemGPTg7tPJswbxC426/xb8qWeoXvkh9O',
'filelocking.enabled' => true,
'memcache.local' => '\OC\Memcache\APCu',
'memcache.locking' => '\OC\Memcache\Redis',
'redis' => array(
'host' => '127.0.0.1',
'port' => 6379,
),
);

What am I doing wrong?
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)